AnsweredAssumed Answered

GeoEvent Service does not receive JSON from polling-Input

Question asked by s_lech05 on Feb 6, 2017
Latest reply on Mar 12, 2018 by rutsch

Hey everyone,

 

I'm polling a JSON from an HTTP endpoint: http://www.stadt-koeln.de/externe-dienste/open-data/parking.php 

If i try writing it to a local JSON or CSV file the GeoEvent Service does not even receive data from the input although in the monitoring section data flow is shown. 

I tried to add different MIME-types just in case; other than this I didn't change a thing in the input definition. The input creates the GeoEvent definition by itself and it looks fine.

Moreover I tried different outputs but the data never flows.The Log shows the normal: Route: 098543c6-c426-460b-8ec5-84481677c074:01072b60-04e0-4254-81e6-dfb359c8dc8e:output:5918f92a-8a59-4b6a-899a-9b8503f1b030 started and consuming from: Endpoint[direct://098543c6-c426-460b-8ec5-84481677c074:01072b60-04e0-4254-81e6-dfb359c8dc8e:output:5918f92a-8a59-4b6a-899a-9b8503f1b030] 

It is also confusing, that when I copy the link in the JSON-validator it gives me an error but if I copy the content it is validating properly.  

Is there any solution? Is there a way to get the content differently so that it validate? Or is the data just not usable here because of the .php?  It might be simple but I'm just not getting it 

 

Thanks in advance

 

I'm using version 10.5.0

Outcomes