AnsweredAssumed Answered

arcpy tool on 10.2 parameter error

Question asked by jongarrido on Dec 9, 2016
Latest reply on Dec 12, 2016 by bixb0012

Hello,

 

I have created an arcpy tool in 10.3 ArcGis version it works perfectly.

 

When trying to open the tool a 10.2  version it throws an error like this:

 

AttributeError: 'Parameter' object has no attribute 'filters'

 

The error is in the last line of the forwarding code

 

param1 = arcpy.Parameter(
displayName='Selected vectors',
name='vetorlist',
datatype='GPValueTable',
parameterType='Required',
direction='Input')

param1.columns = [['GPString','Vector']]
param1.filters[0].type = 'ValueList'

 

 

May be this kind of parameter it's only available from 10.3 on....?

 

Thanks in advance..!!

Outcomes