AnsweredAssumed Answered

Why does my GeoJSON output file keeps showing 0,0 as coordinates?

Question asked by coopernicus1 on Nov 21, 2016

Hi,

 

I'm struggling converting a JSON file to GeoJSON with the GeoEvent extension. From a privacy perspective i can not share the complete file. I have tried several things like putting the complete path from the root to the x and y fields (x and y come in as separate fields). I also tried a Field Mapper processor to check what the exact paths to the coordinates fields are: they are exactly the same as the ones I filled in.
Noteworthy to say is that the file used to be 2 separate files, but I merged the two with use of a Python script. The new file was validated by JSON validators so I am assuming that this isn't the problem. The reason for merging the two files is that both files are about the same location, however, one contains real-time status data and the other contains static data. I've had to merge them because only the static part contains the geometry, while I'm much more interested in the real-time part. Maybe there is a more option that let's me merge the two within GeoEvent without having to use the Python script to do it for me? I've tried to use Field Enricher but, unfortunately, without result. Maybe this has something to do with the static GeoEvent containing the geometry trying to join a real-time stream that has the geometry.

Hope someone could help me out. 

Outcomes