AnsweredAssumed Answered

Make Feature Layer fails when comparing fields in a joined table

Question asked by maribethprice on Oct 27, 2016
Latest reply on Oct 28, 2016 by Dan_Patterson

I am working with two congressional district feature classes. I joined them to compare whether the party changed in the last election. I used Select By Attributes, used the expression cd113.party <> cd114.party, and I thought I got a result.  Then I remembered there is no "Create layer from selected features" in Pro, and I tried the same query in Make Feature Layer.  The expression was validated but returned no results. From then on I could not get it to work either in Select By Attributes or Make Feature Layer, in spite of removing/redoing the join, doing the join in the other direction, restarting Pro, restarting Pro with a new project, etc. etc.  It works with a simple value query cd113.party = 'Democrat', but not with a comparison. I also tried it on a different computer with different data and got the same problem, so it seems pretty persistent.  I have checked all the obvious things: the join does work, the query is valid,  there are some districts that changed parties.

 

Some very strange behaviors coming out of this workflow.

 

This worked fine in ArcMap (I seem to be saying that a lot these days).

 

Any one else experienced this?

Outcomes