AnsweredAssumed Answered

Calculation fails

Question asked by n.ueberschaeresri-rw-esridist Employee on Oct 12, 2016
Latest reply on Oct 17, 2016 by n.ueberschaeresri-rw-esridist

If someone can suggest a better title for my question, please feel free to...

 

I have a problem with the calculation of a field (or with it's result, I don't know):

I have four fields. Not all of them have to be filled but the total has to be 100. To check for this constraint I added a new field (as a text field, also tried as integer field) that adds up the values of these 4 fields (in the calculate attribute):

number(${landuse_share_1})+number(${landuse_share_2})+number(${landuse_share_3})+number(${landuse_share_4}) 

and writes it into the new field ${total}. In the constraint field I say ${total}=100 (also tried ${total}="100").

 

Now in Connect all of my tests worked well but when I try the same on a tablet or my phone (both Android) it seems like the calculation is not performed. Neither is my text/integer field filled nor does the survey accept my values but reminds me that the total has to be 100. The same with Survey123 on my windows computer. 

 

In Connect it shows me straight away a 0 in that field (when Integer), where I expect my total to appear. In the apps, there is just nothing. 

 

Any idea?

Outcomes