AnsweredAssumed Answered

Problem installing Quartz SDK Beta 3 using CocoaPods

Question asked by ShiminCai on Oct 10, 2016
Latest reply on Oct 17, 2016 by ShiminCai

Hi All,

 

I'm following the instructions of the "Get started: Install and setup" in the online documentation to install Quartz SDK Beta 3 using CocoaPods and encountered this problem:

 

garrytoshiba:FCMapApp2 shiminc$ pod install

Analyzing dependencies

[!] Unable to satisfy the following requirements:

 

- `ArcGIS-Runtime-SDK-iOS (= 100.0-beta3)` required by `Podfile`

 

None of your spec sources contain a spec satisfying the dependency: `ArcGIS-Runtime-SDK-iOS (= 100.0-beta3)`.

 

You have either:

 * out-of-date source repos which you can update with `pod repo update`.

 * mistyped the name or version.

 * not added the source repo that hosts the Podspec to your Podfile.

 

Note: as of CocoaPods 1.0, `pod repo update` does not happen on `pod install` by default.

 

My podfile looks like this:

# Uncomment this line to define a global platform for your project

source 'https://github.com/CocoaPods/Specs.git'

platform :ios, '8.0'

 

  target 'FCMapApp' do

  # comment this line if you're not using Swift and don't want to use dynamic frameworks'

  use_frameworks!


  pod 'Dropbox-iOS-SDK'

  pod 'SVProgressHUD', :git => 'https://github.com/SVProgressHUD/SVProgressHUD.git'

  pod 'ArcGIS-Runtime-SDK-iOS', '100.0-beta3'

  pod 'IQKeyboardManagerSwift'

 

  target 'FCMapAppTests' do

  inherit! :search_paths

 

  # Pods for testing

  end

end

 

Actually I'm trying to upgrade a workspace that works fine with the SDK 10.2.5 by changing the line "pod 'ArcGIS-Runtime-SDK-iOS'" to "pod 'ArcGIS-Runtime-SDK-iOS''100.0-beta3'".

 

Can anybody shed any light on what I'm doing wrong please?

 

Many thanks.

 

Shimin

Outcomes