AnsweredAssumed Answered

Strange /User/jenkins error when running Desktop example in Qt

Question asked by addthebadd on Sep 16, 2016
Latest reply on Sep 16, 2016 by addthebadd

I have followed the installation instructions as closely as possible and I think everything went well. I then created a new project using the ArcGIS template. The project compiled without errors but I got the following run time error...

 

Starting /Users/adam/Aerosprite/build-DemoArcGIS-Desktop_Qt_5_5_1_clang_64bit-Debug/DemoArcGIS.app/Contents/MacOS/DemoArcGIS... QML debugging is enabled. Only use this in a safe environment. Initializing application QQmlApplicationEngine failed to load component qrc:/qml/main.qml:16 plugin cannot be loaded for module "ArcGIS.Runtime": Cannot load library /Users/adam/Qt/5.5/clang_64/qml/ArcGIS/Runtime.10.26/libArcGISRuntimePlugin.dylib: (dlopen(/Users/adam/Qt/5.5/clang_64/qml/ArcGIS/Runtime.10.26/libArcGISRuntimePlugin.dylib, 5): Library not loaded: /Users/jenkins/Qt5.4.1/5.4/clang_64/lib/QtOpenGL.framework/Versions/5/QtOpenGL Referenced from: /Users/adam/arcgis/qt10.2.6/sdk/OSX/x64/lib/libEsriRuntimeQt.dylib Reason: image not found) int main(int, char **) QObject(0x0) Error: Your root item has to be a Window. /Users/adam/Aerosprite/build-DemoArcGIS-Desktop_Qt_5_5_1_clang_64bit-Debug/DemoArcGIS.app/Contents/MacOS/DemoArcGIS exited with code -1

 

The strange part is the reference to /Users/jenkins and Qt5.4.1. There is only one user on my laptop and that is me (adam) and I have never installed Qt5.4.1. Any help would be appreciated.

Outcomes