AnsweredAssumed Answered

Regarding arcpy.overwriteOutput Property

Question asked by Hemlata_Sawant on Sep 8, 2016
Latest reply on Sep 9, 2016 by Dan_Patterson

Hi,

I'm facing an issue with the use of arcpy.overwriteoutput property.

 

I have one Python script which performs some Geo-Processing operations and at the end generates one final table named suppose "CITY_NEW". It gets created on the production server after each run of the script daily. I have kept arcpy.overwriteOutput option set to True so that it will always replaces the old table with the newly created one.

 

My issue is, for sometimes script does get ended with the error saying "Table name 'CITY_NEW' #already exists". But sometimes it gets completed successfully without any error. Is it because the output table "CITY_NEW" may be open in some other application or getting accessed by some user while the script is replacing it? I tried doing this by keeping that table open on one system and running the script manually. This also gets ended with the same error. If so, then why here arcpy.overwriteOutput property is not working as expected?

Outcomes