AnsweredAssumed Answered

Related tables not functional on one specific device only

Question asked by berry.bradleyt1 on Jul 29, 2016
Latest reply on Aug 4, 2016 by miaogeng_zhang-esristaff

Disclaimer: I am a student of GIS, very new to the software/field.

 

I have a Feature Service with a related non-spatial table. The relationship works fine in ArcMap, i.e., I'm able to create a record in the related table for a given feature in the feature class. In the web map (see http://arcg.is/2anftHk) , I'm able to view the related table. I made sure pop-ups are configured for the related table, per this article , and generally tried to follow the other guidelines in that blog.

 

Here's the problem: when I open the map in Collector on my phone, a Moto X Pure (Android 6.0 Marshmallow) I am able to see the related table on the details screen for a given feature. When I click View to open the table, the screen changes to my current map view with the related table's title on the app's top bar. The table records should be shown as a pop-up over the map but it's not. Same thing happens when I try to add a new record.

 

I've tried this on an iPad and another Android device (Samsung Note 3) and the related table works just fine. That is, when I click View, I see a pop-up with the records in the table and when I click New, it pops up a screen with a new record form.

 

Is anyone aware of a problem with my particular device (Moto X Pure)? Or any device configuration settings that would cause this problem?

Outcomes