AnsweredAssumed Answered

Why am I getting this error: Failed to validate user credentials for the user... Failed to return user store?

Question asked by janiceb on Jun 23, 2016
Latest reply on Jul 7, 2016 by janiceb

I have ArcGIS for Server 10.3.1 installed on a vm with Windows Server 2012. I am using a Web Adaptor on my web server which is on a different machine. I am using Active Directory for my user store, ArcGIS authentication and roles. This is an intermittent error meaning sometimes my credentials work and sometimes they don't! Here is a screen capture of the error in ArcGIS Server Manager. We do not have HTTPS set-up.

 

This problem happens when I try to log into ArcGis Server Manager. I enter my credentials and get an error that says my username and password are not correct. I hit the Login button again and get the same thing. I get in after 2 or 3 or more tries but I do get in without reentering my credentials so they are correct. Here is a screen capture of the error:

 

I also have some secured services that go through a proxy to display for the public website. Sometimes my users are challenged for credentials and sometimes they are not. This process uses a proxy but displays the same error in the log file so I believe it is the same issue. The proxy does not use the Active Directory because I have a local user credentials in the proxy.

 

I have discussed this with ESRI technical support and the answer is that there is a communication issue between my Active Directory server and my ArcGIS Server. That is just great but I can not find it and I have been looking and my IS folks have been looking!

 

Has anyone else  run into this issue? Has anyone solved it? Are there any suggestions on how to troubleshoot this?

 

Thanks,

Janice.

Outcomes