AnsweredAssumed Answered

no token found

Question asked by jldindc30personal on Apr 8, 2016
Latest reply on May 2, 2019 by charlesletcher

I'm new to Web AppBuilder, and trying to follow the directions here:

Get started—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

I've put the web app builder zip download in my C: direction, unzipped it, and ran the bat file.

The builder opens up my browser (Firefox) to this page:


and gives me the option to specify the URL for my ArcGIS Online organization or portal. I put in my URL and I get a green check mark next to it.


Following the directions in the link above, I go into my content online, Add Item-> Application, and fill in the requirements, such as:

Type: Web Mapping
Purpose: Ready to use, API; Javascript

URL: http://[mymachinename]:3344/webappbuilder

Then add item.

After adding the item, I register it, using redirect URI as http://[mymachinename] and https://[mymachinename]

I then copy the App ID to the clipboard.

In the browser window that Web Appbuilder opened up, I click on the continue button after my

URL: [myorganizationname]

Then it gives me the place to insert my App ID. I paste the app id I get earlier and press continue.

It then gives me a screen where it asks if I will approve or not: "Map 4 wants to access your ArcGIS Online account information" and there's a button to "Approve" or "no thanks". I click approve, and it them simply redirects back to my earlier URL input for my ArcGIS Online organization ([myorganizationname]

When I look at the command window for Web AppBuilder, there's a line that says:

"No token is found, redirect /webappbuilder to /webappbuilder/?action=setportalurl


This happens over and over, even when I create a new Web AppBuilder folder on my C: drive and try the process again with a fresh version. I always get the dredded "No token is found" line in the command window, and it redirects to the set portal url page. I've restarted my machine, closed browser, tried it with Chrome, and still the same problem. I've also tried registering the URI as

http://[mymachinename]:3344 and


as well as

http://[mymachinename]:3344/webappbuilder and


but the result is the same.

What could be going wrong, or what am I doing  wrong?