AnsweredAssumed Answered

Map is not showing when using version 10.2.6

Question asked by EntropiaNico on Oct 7, 2015
Latest reply on Oct 7, 2015 by EntropiaNico

Hello,

 

Recently we've updated our software (.NET and WPF) from ArcGIS Runtime 10.2.5 to 10.2.6.

On all our computers this works fine, except on one machine.

All the computers are Windows 7 with .NET Framework 4.5.2.

 

When starting up our software, we see only a gray background with the Esri-logo.

 

I've tried to figure out what went wrong:

  • Created a new project with only a map (MapView, Map and ArcGISTiledMapServiceLayer) with 10.2.6 (through NuGet)
    • See code below (only added code to this project).
    • Don't work on that machine, works fine on all others.
  • Created the same project with 10.2.6 (with installed SDK)
    • Same result.
  • Created the same project with 10.2.5 (with installed SDK)
    • Works on all machines, even on that machine with the 10.2.6-problems.
  • Watched the traffic with Fiddler on 10.2.6
    • All the tiles are downloaded like on another computer.
    • So I can conclude that the tiles are downloaded, but not shown...

 

Does anyone have any suggestions what else I can do to fix this on that computer?

Reinstalling the computer is not an option, because what to do when it's happens on computer of a customer?

 

The code used for the test projects:

<Window xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:esriControls="clr-namespace:Esri.ArcGISRuntime.Controls;assembly=Esri.ArcGISRuntime"
        xmlns:esriLayers="clr-namespace:Esri.ArcGISRuntime.Layers;assembly=Esri.ArcGISRuntime"
        xmlns:esriSymbology="clr-namespace:Esri.ArcGISRuntime.Symbology;assembly=Esri.ArcGISRuntime"   
        x:Class="MainWindow" Title="MainWindow" Height="350" Width="525">
    <Grid>
        <esriControls:MapView x:Name="MapViewContainer" >
            <esriControls:Map x:Name="MapControl">
                <esriControls:Map.Layers>
                    <esriLayers:ArcGISTiledMapServiceLayer ID="BaseMap" ServiceUri="http://server.arcgisonline.com/ArcGIS/rest/services/ESRI_StreetMap_World_2D/MapServer" />
                </esriControls:Map.Layers>
            </esriControls:Map>
        </esriControls:MapView>
    </Grid>
</Window>

Outcomes