AnsweredAssumed Answered

Cannot get dates right in TimeSeries

Question asked by ethanolevy on Sep 17, 2015
Latest reply on Sep 25, 2015 by ethanolevy

Hello,

 

I'm seeing bizarre behavior when loading dates in to TimeSeries with Text Import.  My data are monthly measurements over twelve years, date only, no time, in an Excel sheet.  I have tried saving as .txt, .csv, with different cell formatting; I've tried various"Date" formats, "Text," "General," and even just entering number of days-since-1/1/1900.  The TsTime field shows the dates as they were in excel, (e.g. "7/24/2002" or "2002-07-24", etc.) but does not use them. Here is what is happening:

 

1. Time Series Grapher shows my groundwater hydrograph with the correct TsValue on the y-axis, but they are perfectly equally spaced and assigned a date starting at 12/30/1899 and each record is one day later, i.e. Wells with 17 records end on 1/15/1900, wells with 125 records end on 4/29/1900, etc.  My data are not perfectly equally spaced, so, even if I ignore the dates, this is bad.

 

2.  I used the empty "UTCOffset" field to try calculating a date field from TsTime.  If I just set UTCOffset = TsTime, they output as days-since-1900, e.g. 38928.   None of the date-related functions in Python or VBScript have succeeded, rather they fail or populate <null> values.

 

3. I've tried various reset-type fixes like creating new excel files, clearing my Temp folder, moving to a brand new map/geodatabase, but no luck.

 

I feel that I've exhausted the google and forum search for similar issues and my clicking finger is sore... I must be missing something.

Any insight?!

 

Thanks heaps

Ethan

Outcomes