AnsweredAssumed Answered

How to debug an OSM import failure?

Question asked by thomaslockhart on Aug 24, 2015
Latest reply on Aug 25, 2015 by CWilkins-esristaff

I've made some local changes to an OSM file which now fails silently when being imported.

 

Status messages indicate that it is at least part-way along reading nodes and ways and "Creating edges and shapes".

 

The changes involve using JOSM to add building outlines, parking lot outlines, and service roads within the parking lots. Other previous local changes (possibly involving building outlines only) are read and propagated correctly. This is a roughly 4k by 4k urban area so there are many features.

 

As you may know JOSM assigns negative numeric values to identifers for local changes. I've tried reading those, tried replacing the minus signs with "m", and tried replacing minus signs with a leading "9999". But since previous changes were read properly that may not be related to the problem.

 

How to debug this? Is it possible to turn up a logging level or ??

Outcomes