AnsweredAssumed Answered

PNG export script failing after upgrade

Question asked by zaloudek on Jul 31, 2015
Latest reply on Feb 5, 2016 by zaloudek

Has anyone else had problems with scripts that export PNGs not working after upgrading versions of ArcGIS?

 

I have a windows box that runs a script using arcpy each day to export > 900 PNGs.  For the last year it's been running fine, with ArcGIS 10.0.  Last week I decided it was finally time to upgrade...  I uninstalled ArcGIS 10.0 and installed ArcGIS 10.3.  My other scripts (that make 50 maps as opposed to 900) continued to work just fine.

 

However, when running the big script, python stops working after about 30 maps have been exported.  This happens whether the script is running via Task Manager or if I'm running it manually using IDLE.  The timing of the failure is not consistent, some times it makes more maps than others.  But, it always fails sooner or later.  I'm including a screenshot of the error dialog boxes I get when running the script with IDLE.

 

I tried exporting JPGs instead of PNGs and got the same error.  I tried lowering the dpi of the images and it didn't help.  I even uninstalled ArcGIS 10.3 and installed ArcGIS 10.2.2, hoping that it was just an issue with 10.3 - but that did not fix it either.

 

Any other ideas?

Attachments

Outcomes