AnsweredAssumed Answered

ArcGIS Online - managing hosted layers not in "My Content"?

Question asked by wroe on Jul 13, 2015

Hi all

 

I've got some questions about ArcGIS Online (AGO) hosted web maps and feature services. For various reasons I am trying to avoid republishing maps so keep that in mind through my questions.

 

1. When I create a WebMap and upload it (and its data) as an AGO hosted service, I see the map itself appear under AGO's "My Content" tab. So good so far. However, I do not see the data layers themselves appear under My Content and am wondering how to manage them. For example, I may want to permanently delete a layer from both the map in question (easy enough) and the AGOL cloud without deleting/republished the entire map. I can find the URL for each layer but don't know what else to do with it (Details > About > More Details ... though a number of them show up with a "Token Required" message, which seems to be a different issue). I assume the WebMap "remove" button doesn't actually delete the hosted data layer it references. I've also tried using www.ago-assistant.com to delete the URL reference in the WebMap, though this just ends up with a broken link in the WebMap (and associated error message).

 

2. If a WebMap is referencing a service (hosted or via ArcGIS Server) which gets explicitly deleted, how do I delete or manage that broken link in the WebMap? Currently an error pops up in the map but, unlike ArcMap, I don't see any means to resolved it (i.e. the broken link doesn't actually show up in the WebMap's "Content" or "Legend" panels). My current workaround is to use the AGO Assistant to put in some other service URL into that layer, get it to appear from the map, and then remove it. Is there a better way to do this?

 

Thanks for reading this far. You can probably see I'm trying to do desktop-type management tasks in AGO. Moreover, I still don't fully understand the data/map management paradigm for AGO.

 

Cheers!
-W

Outcomes