AnsweredAssumed Answered

Same Service, Same Input, Different Outputs.. a Bug??

Question asked by tuna.unsal on May 14, 2015
Latest reply on May 20, 2015 by tuna.unsal

Distances differ when measured in different projection systems. It is for sure. Bu what I am currently facing seems to me kind of a bug.

A simple model that uses the Point Distance tool.. Finds out the settlements within 10km distance of a point.. The version on the left uses a parameter which allows locating the input point when the model is run. The one on the right uses the point feature within the layer and executes the model without an input point parameter.

models.PNG

When the model on the left is run, the very same point is located and the model is executed. Results are of course the same in ArcGIS Desktop.

The projection system of layers are UTM Z38N and varying frame projections confirmed to have no effect on the result. All results match manual measurements in UTM.

Both models are then published as a geoprocessing service and this time run from ArcGIS Server again in ArcGIS Desktop environment. Results are still the same.

Then the geoprocessing services are added as WAB widgets to a web application in Portal for ArcGIS. While the model on the right continues to give the same result, the one on the left starts to calculate distances in Web Mercator causing 20% to 30% differences.

I know the maps in the portal use Web Mercator but;

1)  Why the projection of the map effects the model on the left but not on the right? Same model, same layers.

2)  Why the projection of the data frame does no effect on any of these models in ArcGIS Desktop?

 

If the explanation is "the projection comes from the map when the input is a parameter but comes from the layer when the input is not a parameter but this is only the case in Portal for ArcGIS but not ArcGIS Desktop(with a Web Mercator projection)" then this is definitely a bug.

Outcomes