AnsweredAssumed Answered

Unable to properly configure proxy rules in Webapp builder

Question asked by saip341 on Apr 22, 2015

In Internet Explorer 9, I am seeing CORS issue with an app built using Webapp builder. To resolve this issue I was trying to set proxy rules for those services for which I see errors in the console. Here is a sample of rules I configured.

 

"httpProxy": {
    "useProxy": true,
    "alwaysUseProxy": false,
    "url": "http://localhost:2037/MyApp/resource-proxy-1.0/DotNet/proxy.ashx",
    "rules": [{
        "urlPrefix": "http://tiles.arcgis.com/",
        "proxyUrl": "http://localhost:2037/MyApp/resource-proxy-1.0/DotNet/proxy.ashx"
    }, {
        "urlPrefix": "ArcGIS /",
        "proxyUrl": "http://localhost:2037/MyApp/resource-proxy-1.0/DotNet/proxy.ashx"
    }, {
        "urlPrefix": "http://myOrg.maps.arcgis.com/",
        "proxyUrl": "http://localhost:2037/MyApp/resource-proxy-1.0/DotNet/proxy.ashx"
    }]
}

 

I have tried setting alwaysUseProxy to true, but I still see requests are getting aborted.

http://localhost:2037/MyApp/resource-proxy-1.0/DotNet/proxy.ashx?http://myOrg.maps.arcgis.com/sharing/portals/self?f=jso…

 

Am I missing anything or made any wrong configuration. Please help me in configuring the proxy rules in app's config.json

Outcomes