AnsweredAssumed Answered

How do you use Clip in .NET 10.3 ArcObjects? (c#)

Question asked by klathan on Mar 24, 2015
Latest reply on Mar 26, 2015 by kenbuja

Hi all,

 

I am grabbing a bunch of polygon features (footprints) from a mosaic dataset and I want to clip them and re-add them to the database. I'm getting the records with a Search Cursor within an edit session. So far that part is working just fine, I can update the table fields and Store them back to the db.

 

I'm running into trouble when I try to clip the features. I cannot seem to get the parameters right. It complains with every kind of output I've tried. Ideally I'd output back to the original input feature, but failing that I'd like to output to memory. I tried creating a memory workspace, but I don't know how to get the results of the clip into it. Has anyone ever done anything similar? The documentation on using geoprocessor in ArcObjects doesn't seem very clear.

 

It seems funny it's so incredibly easy to do what I want in ArcMap 10.3 and it's so hard programmatically. I can start an edit session, select my records, select my clipping feature, and hit the Clip in the Editor menu, and boom... done. But it doesn't seem like the Editor clip method is exposed in ArcObjects.

 

Thanks!

 

-Ken

Outcomes