AnsweredAssumed Answered

Map service using SOE on Linux not starting

Question asked by jgreco on Dec 9, 2014
Latest reply on Apr 15, 2015 by jgreco

We are currently looking into moving to Linux for our ArcGIS Server environment.  The last piece I need to implement before we can do this is rewrite our C# SOEs in Java, which I have found fairly easy to do, but I have run into some issues when deploying it to my site.

 

I am able to export the .soe file, add the extension to my site in manager, but when I add it as a capability on one of my map services, the map service never starts.  I was able to deploy the same Java SOE on one of my Windows ArcGIS Servers and the map service starts fine and the SOE functions as it should.  I also have tried this using one of Esri's samples and I see the same behavior.  I have tried debugging it in Eclipse, but it never breaks since the map service never actually starts.  I have also set my logging to DEBUG, but do not see any messages as to why the service is not starting.

Outcomes