AnsweredAssumed Answered

3D Model Export with non-existing textures

Question asked by o.ertacesri-de-esridist Employee on Nov 7, 2012
Latest reply on Nov 8, 2012 by o.ertacesri-de-esridist
Hi,
I couldn't find a related discussion, sorry if the issue has already been discussed.
Version: CE 2012.1

I have some simple building models in CE, and I want to visualize and animate them in 3D Max. The export format is Fbx.
For the rule file I've copied and re-edited Tutorial 15 Facades rule and related assets. Later on I've created my own Window and facade textures, and replaced with the existing textures. Old textures were totally deleted from the system. (see figure), and previews updated.

CE can easily visualize and generate the models with my new textures. But the problem is (as you can see at the figures attached), 3D Model export collects all existing and non-existing textures together.
And this ends up with a texturing failure in 3D Max. Some windows are visualized without a texture etc...

Am I missing a point during the export or making a mistake in the rule file. For instance I have the random window texture variable as - randomWindowTexture = fileRandom("*facades/textures/window.*.tif") - in the rule; is it maybe checking all workspace even Tutorial 15 and collecting all textures named window. ?
Or CityEngine is caching the textures somewhere that I don't know.

Thanks in advance for the response!

PS. I've deleted and reloaded my building shapes, and re-generate the model several times. But it didn't change a thing...

Cheers
�?zgür

Attachments

Outcomes