AnsweredAssumed Answered

Geoprocessing service failed to delete existing output

Question asked by geonetadmin on Jan 11, 2012
Latest reply on Jan 12, 2012 by geonetadmin
Original User: obelgrubel

Dear experts,

I created a really simple geoprocessing (just buffering some points) and publish it as Geoproc Service. I make a web app which has this geoproc.
When I run the geoproc service within web app, i get an error :


Executing (Model2): Model2 "303 Meters" Start Time: Wed Jan 11 16:57:38 2012 Executing (Buffer): Buffer xxxx.gisadmin.test_buff_pt C:\student\test_buff_pt_Buffer.shp "303 Meters" FULL ROUND NONE # Start Time: Wed Jan 11 16:57:38 2012 ERROR 000258: Output C:\student\test_buff_pt_Buffer.shp already exists Failed to execute (Buffer). Failed at Wed Jan 11 16:57:38 2012 (Elapsed Time: 0.00 seconds) Failed to execute (Model2). Failed at Wed Jan 11 16:57:38 2012 (Elapsed Time: 0.00 seconds)


The problem is the geoproc service failed to delete the existing output file (C:\student\test_buff_pt_Buffer.shp). After I delete the output file manually and run the geoproc service again, it works.. I have also redirect the output to a geodatabase and it failed too with the same error message.

Why does the geoproc service failed to delete the existing output file ??? The location of the output is the same as the location of the published mxd.
The geoprocessing model is fine when run in ArcMap without having to delete the existing outputs manually.

Here I attach the model and the geoproc settings.

Please kindly help. Thanks

Attachments

Outcomes