AnsweredAssumed Answered

Python issue

Question asked by ldcarto on Aug 20, 2014
Latest reply on Aug 25, 2014 by curtvprice


Hello,

 

I have created python scripts in while I was in ArcGIS 9.3.1.  The scripts all worked correctly in 9.3.1 and when I upgraded to 10.1 as well.  Now, however, since I have upgraded to 10.2.1, many of the scripts are not working.  I tested the models in ArcCatalog and they do work fine there, but when the models are ran through a python script, I get errors regarding mdb files not being supported or found.

I tried exporting the models to python scripts and entering those in instead of using the arcpy command to run the model, and the errors still come through.

 

I have noticed there tends to be an issue with any of the scripts that include an mdb file.  I have to use that format because they are grabbing data from Access databases.

 

A sample script is attached below for you to review.  The part of the script that triggers the mdb file in Access works correctly.  So, python does still open an mdb.  It just fails when trying to access an mdb file through a model......even though it works correctly in the model itself.

 

Any help at all would be greatly appreciated.

 

Thanks,

Lisa

Attachments

Outcomes