AnsweredAssumed Answered

Unable to publish python script as geoprocessing service

Question asked by dztt on Aug 6, 2014
Latest reply on Aug 12, 2014 by khibma-esristaff

I have run into an issue with an ArcGIS server and ArcMap (10.1 SP1) setup that I am hoping someone may have also run into.  I am trying to publish a python script as a  geoprocessing service in ArcMap on a client’s server.  The script runs and publishes without issue on my personal machine, a development machine, and a development machine my client provided for us on their network.  However, on the clients production server as soon as you click Analyze or Publish, from within the publishing wizard, ArcMap hangs, one CPU maxes out, and the process never returns.  No error messages are ever displayed or logged. This seems to be an issue with any geoprocessing tool that uses a python script, as publishing a standard Arc toolbox tool works.  I have tried running the Arc Toolbox tool that the wizard runs behind the scenes (Stage Service) and I get the same result.  I have also tried running the toolbox tool directly from a python interpreter and also get the same result.  I have tried about everything I can think of except reinstalling ArcMap.  Just to verify my python script isn't the issue I have tried publishing a script that only takes a single input and returns that same output.  This also does not work.

 

Any suggestions or ideas of things I could try they would be much appreciated.

Outcomes