AnsweredAssumed Answered

GP Tool - Schema Locking Error with Geocoding Process

Question asked by ipeebles on May 25, 2014
Latest reply on May 27, 2014 by ipeebles
I have a question. I have created a python tool that has two input parameters. These parameters include (input initials) and (input date). After these parameters are entered in the tool runs and maps building inspections. The output results show a colored point wiwith the matching colored label based on the input initials. The tool runs fine in desktop and publishes to ArcGIS Server.

In ArcGIS Server, the tool runs well, but when another user runs the tool simultaneously, both user get schema locks in regards to the geocoding service causing the tool to fail.


How can I prevent these schema locks? The weird thing is that this tool worked before. I am running ArcGIS Server 10.1 SP1.

This is how my locator is called out within the tool:

AddressesWithBldgNo = r"e:\locators\AddressesWithBldgNo"

scratch workspace is set when I run the tool = e:\outputworkspace

I have a share set up. Why would I get a schema lock? How can I use the address locator without getting a schema lock when multiple users are hitting GP service. Any help will greatly be appreciated.

Here is a screenshot of the error message I am getting in the Silverlight Application.[ATTACH=CONFIG]34071[/ATTACH]

Ian

Attachments

Outcomes