streetjp

Problem using > or < in REST query

Discussion created by streetjp on Aug 5, 2010
Latest reply on Jan 9, 2013 by juhunter
We seem to be having a problem using > or < in queries against our ArcGIS Server 10 map services. The problem originally started when trying to set the where clause in the query from our flex application to something like OBJECTID>1. Setting it to something like OBJECTID=12345 works fine.

I then tried this from the query html page for the rest endpoint and got a similar error when using the Query (Get) button on the page . The Query (Post) button works fine. This also eliminated the problem from being something wrong with the Flex API.

From the query page The error basically give the internet explorer page not found error and the URL being sent is

http://server1/ArcGIS/rest/services/App_MapServices/Electric_Distribution/MapServer/2/query?text=&geometry=&geometryType=esriGeometryPoint&inSR=&spatialRel=esriSpatialRelIntersects&relationParam=&objectIds=&where=esri_id%3E1&time=&returnIdsOnly=false&returnGeometry=true&maxAllowableOffset=&outSR=&outFields=modified_date&f=html[/url]

When trying a similar query against one of ESRI's example map services everything seems to work fine. Has anyone else experienced this problem or know of a setting that maybe we missed when setting up the Map Service. Everything worked fine for us at 9.3.1

Thanks In Advance

Outcomes