ellierusack

Topo to Raster batch processing error

Discussion created by ellierusack on Jan 22, 2013
Latest reply on Oct 18, 2013 by slynch-esristaff
Hello,

I have a problem with a script for batch processing point elevations and streamlines using topo to raster to interpolate a DEM.

Essentially we use another script that clips a 90m dem and streamlines to 1x1 degree cells and converts the dem to point elevation. The second script loops though all of the clipped point elevation and streamlines, along with a boundary feature class, and re-interpolates the DEM using topo to raster.

The Topo to Raster script worked relatively fine in v10 however now that I am trying to run it in 10.1 it fails after 13 loops. Last year it failed after 28 loops but it has now started going for only 13 loops

When it fails, if it is running in the foreground arcmap just closes without any error message. I have been writing the errors to a logfile and it just stops writing to the logfile, there is no error message. If it is running in the background it just tells me that it has failed but gives no error message - the only messages in the geoprocessing results are "executing, start time, and running script..."

In 10 it would crash arc occasionally with a visual fortran error but it would always crash on the same cell and I fixed it by using a lower value for the margins.. In 10.1 it is consistently crashing after 13 loops so i dont think it is the same problem (changing the margins does not fix the problem)

Has anyone had this problem before, I'm completely stuck...! I've attached the script to this message

Thanks in advance for any help

Attachments

Outcomes