npssde

Script tool (v10.1 SP1) raster layer display problem

Discussion created by npssde on Jan 7, 2013
Hello,

Trying this post again, hoping to attract post-holiday reviews/assistance...

I have a script tool (originally written in 10.0 SP5) that generates raster layers, then adds them using a derived
output script tool parameter. The tool/script works great in 10.1 SP1, except for the final step of adding the raster layers to the
map (using arcpy.SetParameterAsText()). The layer is added correctly IF no symbology is used. However, if symbology is set
by populating the Parameter Properties Symbology value in the tool, ArcMap crashes when adding the raster layer. I've tried with both the default *.lyr file, which was created in 10.0 SP5 and a new *.lyr file created with 10.1. Same result if symbology is applied
via the script tool (==ArcMap crash).

Not sure why the auto-symbology fails so spectacularly... These are file geodatabase rasters, un-signed 8-bit, nothing special...

Here's a zip archive with a map package (v10.0) and the toolbox. If it is run in 10.1, the outputs will be created correctly but ArcMap will crash when adding the raster layer if symbology is used (Scripts\GenericLandcoverLACScript_ScriptTool.py, line 71).

Any help appreciated!

Thanks,
Lisa

Attachments

Outcomes