WAB error on IE11

898
6
02-25-2019 09:50 AM
rajujee
New Contributor II

Hello experts,

My WAB application is not working with latest WAB Developer Edition (v2.11) in IE11 only.  It shows continuous loading size in the browser.

I get error on init.js

Error: abort("Assertion failed: no binaryen method succeeded."). Build with -s ASSERTIONS=1 for more info.

I am using a custom widget that requires me to use WAB Developer Edition.

PLEASE HELP!

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor
0 Kudos
rajujee
New Contributor II

Thanks Rob for quick response. I am using latest version v2.11. It is totally different error 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Raju,

  Is The application running in compatibility mode in IE?

0 Kudos
rajujee
New Contributor II

Thanks Rob for always being helpful. Application is not running on compatibility mode.

Do you suggest to implement following code as a work around ?

IE11 support broken due to emscripten issue · Issue #96 · medialize/sass.js · GitHub 

if (!self.crypto) {
self.crypto = {
getRandomValues: function(array) {
for (var i = 0, l = array.length; i < l; i++) {
array = Math.floor(Math.random() * 256
}
return array;
}
};
}

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

No. I am not having an issue with WAB 2.11 in IE 11... So I am not sure what you issue is if your app is running in Edge mode and not compatability mode.

0 Kudos
LeonWoodhouse2
New Contributor III

I am also getting this problem. Same version of IE and WAB. Was there any solution?

Thanks.

0 Kudos