Identify Widget - Point Activate on Startup

323
9
08-13-2019 07:07 PM
RodWoodford
Occasional Contributor III

Hi Robert,

Is it possible to have the point selection tool active on startup so the user can simply click on the map without first activating the point selection.

cheers

0 Kudos
9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor
0 Kudos
RodWoodford
Occasional Contributor III

Thanks Robert I tried this, it doesn't seem to default on. The user needs to manually activate it. I'm using WABD 2.1.2.

Cheers

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Rod,

   So you have the widgets settings set as shown in the image attached and you are not getting the point auto activated?

The screenshot is from WABDev 2.12 and it is working fine for me.

0 Kudos
RodWoodford
Occasional Contributor III

Yep I have the same configuration as you, however I'm using the dashboard theme including both the eSearch and Identitfy widgets. Could this be causing a conflict? See image of design below.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Rod,

   Do you happen to have the eSearch set to auto-activate the point graphical search tools?

0 Kudos
RodWoodford
Occasional Contributor III

No its set to NONE. Its weird because it saves ok but when I run the app the eSearch point default activates and the identify does not.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Strange I added both to the tab theme and the same panel in a tab and did not have an issue unless I set the eSearch to have a graphical point auto enabled. Do you have the eSearch or the identify widget set to open at startup?

0 Kudos
RodWoodford
Occasional Contributor III

No. I think the issue is relating to the map extent settings. WABD saves the activation on when set, but when I run the app because the layer used by the identify widget is not visible at the starting extent, the activation is defaulting back the the esearch widget setting. Would this be a likely reason? I will play around with this, but I don't really want the layer to be on at the map extent. Hope this makes sense.

cheers

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Rod,

   You should do some testing on your side. Try removing the eSearch and see if you get the same result. See if there are any web console errors.

0 Kudos