eSearch widget

663
12
07-01-2021 08:38 AM
ShannonSmith
New Contributor II

I have installed the custom WAB widget into the proper places and it does not show up in the widget areas. What am I doing wrong? Any help is appreciated.

0 Kudos
12 Replies
GregHorne
New Contributor III

@RobertScheitlin__GISP  I must be doing something fundamentally wrong in that I have rolled back to wab.2.16 and eSearch2.12 and am getting the same error.  I presume the AppID is correct since I can choose a template  and setup an App and run it.  I will be retracing my steps...

 

GregHorne_0-1626096864414.png

 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

@GregHorne I am not a Portal so I can only advise how things work with WAB Developer. In WAB Dev when you update a widget to a new version you replace overwrite the client/stemapp/widgets/eSearch folder with the new code and this updates all NEW apps produced. To Update an existing apps widgets you have to update the server/Apps/[App#]/widgets/eSearch folder. The fact that you are getting the same error still is telling me that you are not getting the updated code in the app you are testing for some reason.

0 Kudos
GregHorne
New Contributor III

@RobertScheitlin__GISPJust to follow up:

Widget.js

_addCustomStyle: function(theme) {
var customStyles = lang.getObject('customStyles', false, theme);
if(!customStyles || !customStyles.mainBackgroundColor || customStyles.mainBackgroundColor === ""){
return;
}
var rgbArray = Color.fromHex(customStyles.mainBackgroundColor).toRgb();

The best I can tell the"var rgbArray =" line appears to be throwing the error so I added a "return;" statement prior to this line and everything started working.

0 Kudos