HEC GoeRAS - GeoHMS  Problem Solvers

4954
5
01-19-2012 06:10 AM
Labels (1)
MarkBoucher
Regular Contributor II
This is a collection of actions I've learned to take when I'm having problems with ArcHydro or HEC-GeoHMS. I'll add to the list when I find more.

  1. Make sure the Geoprocessing extents include the whole project: Go to the Geoprocessing menu>Environments...>Processing Extent. Under Processing Extent choose a layer that you know covers the full extent of the waters you are processing and click OK. This should ensure that the processing extent is large enough to do what you want.

  2. Delete everything you can in your temp folder: Mine is C:\Users\mboucher\AppData\Local\Temp. Get out of ArcMap first to clear temp files related to your project. You can do this without getting out of ArcMap through the ArcHydro Toolbar under ApUtilities>Additional Utilities>Clean User's Temp Folder.

  3. Make sure your Target Locations are correct: Under ApUtilities>Set Target Locations, make sure the HydroConfig and they GeoHMSConfig Targets make sense. The raster data should go to the project folder vector data to a geodatabase. The raster data will go to a folder in the project folder with the dataframe name and the vector data to a feature data set with the dataframe name. Through the ArcHydro Toolbar under there is a function to reset the target locations: ApUtilities>Additional Utilities>Reset Target Locations. I've not tested this to see if it corrects everything.

  4. When working on a complicated model, don't use the model mxd for your presentation map. It just adds baggage to an already "heavy" mxd.

If you have additional actions or clarifications on these, please chime in.
Tags (2)
0 Kudos
5 Replies
MarkBoucher
Regular Contributor II
One more thing... I've gathered from other posts that when using GeoHMS, things work better if you turn off background processing. Go to Geoprocessing>Geoprocessing Options... and uncheck "Enable"  under "Background Processing".
0 Kudos
neilo_brien
New Contributor
Errors when running tools from HEC-GeoHMS toolbar.

Workaround:
Do not enable the Background Processing option on the Geoprocessing Options editor.

1. Go to Geoprocessing, Geoprocessing Options�?�
2. Make sure the Enable checkbox is not checked under Background Processing.

If background processing was checked then start the GeoHMS project over.
0 Kudos
MarkBoucher
Regular Contributor II
I've started a practice that seems to make many errors/crashes go away.

Layers/rasters needed for Arc Hydro are:

  • DEM PROCESSING:


    • rawdem (Extracted by mask from county-wide dem for each project. Set processing extents using this or mask ploly)

    • agreestream*

    • innerwalls*

    • outerwalls*

[INDENT]*I do work all over my County and so have county-wide "master" geodatabase for these that I use on all my Arc Hydro Projects.[/INDENT]

  • WATERSHED DELINEATION:


    • BatchPoints

If I have these layers, I can recreate the hydrologically correct DEM (HC DEM) anytime I want and re-delineate the watersheds.

So my practice is this: As I'm developing my HC DEM, and have to modify the agreedem, innerwalls, outerwalls layers, I can save the BatchPoints to my project folder and then delete the geodatabase and folder with rasters in it (Target Locations). This starts everything fresh and new. Then I can use model builder to reprocess the watersheds. When I'm ready to re-delineate the watersheds, I copy the BatchPoints into the geodatabase and set the BatchDone value to "0".

I run the watershed delineation, etc. via the Arc Hydro menus though I could possibly do this via Model Builder also. Since I've started doing this (and following solutions in the postings above on this thread), my crashes and errors have all gone away! Here is the ModelBuilder model for my latest project. I don't use outerwalls on this project, but that could be added.


[ATTACH=CONFIG]18585[/ATTACH]
0 Kudos
MarkBoucher
Regular Contributor II
0 Kudos
JONATANTEIXEIRA
New Contributor
I found some way. The soluction is simple.

Change the name of mxd with maximum 8 caracteres and last save in C: with short way. Exemple: C: Hecbase

I have the self problem. But resolve this way.

Jonatan Teixeira. Brasil. Minas gerais[ATTACH=CONFIG]26780[/ATTACH]
0 Kudos