"Failed to load notebook" when using custom environment

11-21-2022 03:38 AM
New Contributor II

I've set up a cloned custom Python environment in ArcPro 3.0.2 to set up the r-arcgisbridge package.

Cloning the environment and installing the package work ok, but when opening a notebook, I get an error, "Failed to load notebook".

If I switch back to the default environment I can load a notebook ok.

Any advice on how to fix this?



12 Replies
New Contributor

I've been in touch with someone from the ESRI customer care team UK and they advised to clone the environment via the Python command prompt as described here: https://support.esri.com/en/technical-article/000020560, before then installing packages in cloned environment. I haven't tested this extensively but when I tried briefly, this seems to have hopefully solved it for me (I tested with installing rasterio and then geopandas only).

0 Kudos
New Contributor

I have tried that a couple different times and still can't install r-arcgis-essentials unfortunately.

0 Kudos
Esri Regular Contributor

Yes, that's right, we needed to add a fix on our end to make this work. One of the challenges with conda and custom packages is, once you've released something you effectively can't take it back because it'll be installed and used, and if the dependencies aren't specified tightly, conda will always choose the version that is "easiest" for it to solve, which in this case involved bad dependencies.

We've put the fix up which can be added to any custom environment by installing the `pro-notebook-hotfix` package. There are also details on how to do this in the first question of the Pro Notebooks 3.0 FAQ:


If it is available to you, you can also upgrade to Pro 3.1 which works out of the box without needing to add any additional packages.



0 Kudos