OpenSSL issues with Windows 10 ArcGIS SDK

02-09-2021 08:15 AM
New Contributor III

Hello Esri Community,

I primarily use Qt Creator and ArcGIS SDK for QT on a Linux, and been doing so for awhile.

I recently decided to download QT Creator on my home PC which runs on Windows 10.

I have QT Creator 15.2, and ArcGIS 100.10. 

The issue I am having is that when I create a simple ArcGIS Widgets application, it crashes as soon as you run it, which history tells it's OpenSSL issue, MAYBE! (I could be wrong)

What essentially is happening is the application is crashing as soon as you hit run, no errors.

I downloaded OpenSSL from this link:

I downloaded: Win64 OpenSSL v1.1.1i


I have also tried installing OpenSSL through the QT Maintenance Tool, but it still crashes as soon as I run the program which btw, is the base code on creating a new ArcGIS Widget program. Either way, I am looking for assistance, I just want to be able to use ArcGIS SDK 100.10 on my Windows PC but it's not being nice to me.

Any advice?


Tags (4)
0 Kudos
2 Replies
Esri Frequent Contributor



The OpenSSL version is correct -


Did you make sure to either copy those dll's into your Qt kit's bin folder or add it to your PATH? They need to be somewhere that will be picked up at runtime by the app.


If you've done all this, are you certain the crash is related to OpenSSL? Usually when I don't have OpenSSL libs present, I just don't see any maps being display - I still see the Window and the MapView's attribution bar at the bottom. What messages do you see in the application output console? What is your call stack?

0 Kudos
New Contributor III


You are correct. I remember now that when it was an OpenSSL issue on my Linux machine, the map wouldn't load but the application did.

I'll to follow the stack trace when I get home. Thank you very much for responding.

0 Kudos