Problems with ArcGIS Pro package installer / conda

165
3
2 weeks ago
ChrisRingo
New Contributor III

Hello all,

Some time after upgrading to Arc Pro 2.7 (now on 2.7.2) I lost the ability to install anything via the python package manager. In particular I've been trying to re-install Spyder ('cause of course it didn't install with the Arc Pro update).  After cloning the default environment as usual and trying to install spyder using "Add Packages", it just goes away for a short bit and nothing gets installed.  So I went to the command line (using "proenv.bat), and tried installing it from there, but get the following error:

"CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/PKG-INFO'
specified in the package manifest cannot be found."

I've uninstalled/reinstalled Arc Pro a couple of times, deleting the old cloned-environment folder each time, but have gotten the same result.

Any ideas anyone?

Thanks for any input!

Tags (2)
0 Kudos
3 Replies
DanPatterson
MVP Notable Contributor

don't use pip to install spyder.  also, there are some technical difficulties with spyder, so ...

>>> conda install spyder=4.2.5 --no-pin --dry-run

Now, examine what is going to happen...  If you are installing into a clone, you can drop --no-pin

when you know what might happen, drop the --dry-run


... sort of retired...
ChrisRingo
New Contributor III

Hi Dan, thanks for the response. I should have been clearer - the command I used to try the installation was simply "conda install spyder", without the version number - I didn't actually invoke pip from the command line.  Including the version in the install command doesn't change the outcome. And actually, that was only the first error of a very long string (I copied the first several errors at the bottom of this msg - they're all similar).  

The missing files actually are missing from the cloned environment, but they're there in the default environment.  Copying them over by hand results in the same errors though, so not sure what to do next.  Maybe I'll just use Jupyter for everything instead.  I do like Spyder a lot but not sure it's worth the headaches each time I upgrade Pro.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/PKG-INFO'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/SOURCES.txt'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/dependency_links.txt'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/entry_points.txt'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/not-zip-safe'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip-21.0.1-py3.7.egg-info/top_level.txt'
specified in the package manifest cannot be found.

CondaVerificationError: The package for pip located at C:\Users\ringoc\AppData\Local\ESRI\conda\pkgs\pip-21.0.1-py37haa95532_0
appears to be corrupted. The path 'Lib/site-packages/pip/__pycache__/__init__.cpython-37.pyc'
specified in the package manifest cannot be found.

...

etc.

0 Kudos
DanPatterson
MVP Notable Contributor

conda install spyder=4.2.5

There are some issues with spyder 5.0 for the next little while until they get it figured out, just install the last stable version

PS.... I install everything in the main/base environment if that is an option for you, 

will install dependencies,  pip isn't one of them

# Mandatory:
atomicwrites >=1.2.0            :  1.4.0 (OK)
chardet >=2.0.0                 :  4.0.0 (OK)
cloudpickle >=0.5.0             :  1.6.0 (OK)
diff_match_patch >=20181111     :  20200713 (OK)
intervaltree >=3.0.2            :  3.1.0 (OK)
IPython >=7.6.0                 :  7.21.0 (OK)
jedi =0.17.2                    :  0.17.2 (OK)
jsonschema >=3.2.0              :  3.2.0 (OK)
keyring >=17.0.0                :  21.4.0 (OK)
nbconvert >=4.0                 :  5.6.1 (OK)
numpydoc >=0.6.0                :  1.1.0 (OK)
paramiko >=2.4.0                :  2.7.2 (OK)
parso =0.7.0                    :  0.7.0 (OK)
pexpect >=4.4.0                 :  4.8.0 (OK)
pickleshare >=0.4               :  0.7.5 (OK)
psutil >=5.3                    :  5.8.0 (OK)
pygments >=2.0                  :  2.7.0 (OK)
pylint >=1.0                    :  2.7.4 (OK)
pyls >=0.36.2;<1.0.0            :  0.36.2 (OK)
pyls_black >=0.4.6              :  0.4.6 (OK)
pyls_spyder >=0.3.2             :  0.3.2 (OK)
qdarkstyle >=2.8;<3.0           :  2.8.1 (OK)
qtawesome >=0.5.7               :  1.0.2 (OK)
qtconsole >=5.0.3               :  5.0.3 (OK)
qtpy >=1.5.0                    :  1.9.0 (OK)
rtree >=0.8.3                   :  0.9.4 (OK)
setuptools >=39.0.0             :  50.3.0.post20201006 (OK)
sphinx >=0.6.6                  :  3.5.3 (OK)
spyder_kernels >=1.10.2;<1.11.0 :  1.10.2 (OK)
textdistance >=4.2.0            :  4.2.1 (OK)
three_merge >=0.1.1             :  0.1.1 (OK)
watchdog >=0.10.3;<2.0.0        :  1.0.2 (OK)
zmq >=17                        :  19.0.2 (OK)

# Optional:
cython >=0.21                   :  None (NOK)
matplotlib >=2.0.0              :  3.3.1 (OK)
numpy >=1.7                     :  1.19.1 (OK)
pandas >=1.1.1                  :  1.1.1 (OK)
scipy >=0.17.0                  :  1.5.2 (OK)
sympy >=0.7.3                   :  1.5.1 (OK)

 


... sort of retired...
0 Kudos