Parallel processing disabled only when called from Python script

3789
1
03-10-2015 09:23 AM
PaulCone
New Contributor III

I have a Python script that builds tile packages from a set of .mxds.  I created this script last fall, and from the beginning it has always defaulted to using multiple cores (I have a four core machine).  The script runs in IDLE.  It would always say "Generating tile cache using 4 parallel instances."

Months later and I have to run this script again to generate new tile packages.  Now when I run the script it says "Parallel processing has been disabled for the tool on this product."  To the best of my knowledge I have not changed my ArcGIS configuration.  When I run the same process on the command line in ArcGIS it still says "Generating tile cache using 4 parallel instances."

So somewhere in the process of the script calling arcpy, the parallel processing is being denied.  I have half a dozen sets of tiles, and so now what used to take 8 hours is taking over a day.

I've scoured the internet, checked my scripts, checked the licensing for ArcGIS, talked to our network security team about McAfee possibly interfering with it, and I am stumped.  I even tried forcing the parallel processing by setting arcpy.env.parallelProcessingFactor = "100%" but then the script errors out, saying "ExecuteError: ERROR 001493: The tool does not support parallel processing on this product."

I'm running ArcGIS 10.2 and Python 2.7.3 on Win 7 Pro.

Anyone have an idea?

Paul

-------------------------------------------

Paul Cone

Corporate GIS

Bureau of Technology Services

City of Portland, Oregon

paul.cone@portlandoregon.gov

0 Kudos
1 Reply
PaulCone
New Contributor III

After trying many things it was an uninstall and reinstall of ArcMap that fixed this.  Oy.

0 Kudos