Missing Environments in Python Package Manager

1244
3
06-01-2017 03:52 AM
SimonJackson
Occasional Contributor III

Running ArcGIS Pro 1.4 on a Windows 10 machine.  Also have Anaconda installed.

When I create a new project in ArcGIS Pro, I get the following under the Python Package Manager:

What steps do I need to carry out to fix this up?

0 Kudos
3 Replies
JoshuaBixby
MVP Esteemed Contributor

You say, "when I create a new project," what about opening an existing one?  Same thing?

It may be something got crossed when installing one of the Python distributions.  To start, I would check the registry to see what the values are for the ArcGIS Pro Python environment and make sure they are either set correctly or the files exist on the local hard drives:

C:\Users\bixb0012>reg query HKLM\Software\ESRI\ArcGISPro

HKEY_LOCAL_MACHINE\Software\ESRI\ArcGISPro
    InstallDir    REG_SZ    C:\Program Files\ArcGIS\Pro\
    ....
    PythonCondaEnv    REG_SZ    arcgispro-py3
    PythonCondaRoot    REG_SZ    C:\Program Files\ArcGIS\Pro\bin\Python
    ....
ClintonDow1
Occasional Contributor II

There is a utility in the %ProInstall%/bin/Python/Scripts directory called 'proswap.bat' - you can use this batch file with an env name as an argument to automatically switch the necessary registry keys. Since there is no environment in the drop-down, I'm wondering if the %ProInstall%/bin/Python/envs/arcgispro-py3 folder still exists? The UI should be able to read the package information from that folder without the registry being set.

You may also want to check the PATH variable to ensure the Anaconda install isn't stealing your conda commands - currently we require envs to be within the Pro folder structure, so if they are in the Anaconda envs directory they won't work with Pro. They can exist side by side you just need to be mindful of the PATH. 

SimonJackson
Occasional Contributor III

Thanks everyone for the extra info.  It was due to Anaconda setting the PATH variable.  

I actually fixed it by installing the beta v2.0 of Pro and this corrected the PATH for me.