How to set up x64 Python in ArcMap

07-01-2019 07:37 AM
New Contributor

I'm currently making a script to automate multi-map construction within ArcMap. This script requires the use of win32print to change my default printer prior to saving the map. I have win32print installed from this link:

I have a standalone Python 3.7 64bit installed, a 32bit Python for Arcmap, and a 64bit Python installed for Arcmap, which was installed when I installed 64 bit background geoprocessing. When I run python through the toolbar button, I run the following script:

import sys


And it shows that it's running a 32bit instance of python, which came installed with ArcMap, even though I have x64 bit background processing installed and enabled. How do I go about updating this to run the 64 bit python, whether the one I downloaded that's x64 "ArcGISx6410.7" or my x64 standalone Python?

Any help would be greatly appreciated!

Edit 7/2/19: Durr, I had pywin32 pip installed into my standalone 64 bit instance of python, so obviously it wouldn't run inside ArcMap's x32 instance of python. Pip installed to the correct directory, and now that library works fine for me. But i'd still prefer Arcmap to use x64 Python. I assume it's a registry re-path that i'd have to do. 

0 Kudos
0 Replies