Errors Running GP Models With Python Script

339
3
04-04-2018 08:06 AM
JoshSaad2
New Contributor II

I'm getting an error whenever I try to run a python script outside of ArcGIS Pro that executes geoprocessing tools that I made.  The purpose of the tools is to ETL data from outside databases into my GIS database.  I created python scripts using arcpy.ImportToolbox to run these tools so that I can schedule them to run overnight automatically, based on this article.  The individual commands all ran fine using the Python window in ArcGIS Pro, but I keep getting the error in the attached screenshot.

Python Error

I ensured that I'm using the correct Python shell , 3.6.4, located in the ArcGIS Pro folder.  I was thinking that the problem may be because my model pulls data from other database connections, but I'm not sure. If anyone can help me with this  I would greatly appreciate it.

0 Kudos
3 Replies
BruceHarold
Esri Regular Contributor

Josh does this use Data Interoperability extension?  If so you'll need to check out the extension in your script.

0 Kudos
JoshSaad2
New Contributor II

I'm not using Data Interoperability, just feature to feature, append, dissolve, calculate field, and delete rows.  Thanks though.

0 Kudos
GaryBarden
New Contributor III

I just ran into this problem. Were you ever able to find a solution?

0 Kudos