Enterprise database in arcpy

1167
5
08-26-2016 03:55 AM
Haider_AliFaheem
New Contributor II

Hello Everyone,

i am trying to run the solve vehicle routing problem.i have created the enterprise geodatabase and add all the required features.but i am getting the following error on "arcpy.na.SolveVehicleRoutingProblem".

ERROR 000837: The workspace is not the correct workspace type.

i have also tried to create the model with model builder to solve the vehicle routing problem and save the out put in enterprise geodatabase but still getting the same error.please have look on the screenshot for model builder error and python error.

i am also getting the same issue with "in_memory" database.

script runs fine on file geodatabase.

0 Kudos
5 Replies
DanPatterson_Retired
MVP Esteemed Contributor

the line with the error is hidden

0 Kudos
XanderBakker
Esri Esteemed Contributor

I assume that the output workspace is "C:\\temp\\vrp\\MOLZA.sde". Just a question... you do have a Standard or Advanced license (because you are writing to an Enterprise GDB, which is a change of the schema). Do you have sufficient permission to write to the EGDB?

0 Kudos
Haider_AliFaheem
New Contributor II

Thanks Xander Bakker for your quick reply.yes output workspace is "C:\\temp\\vrp\\MOLZA.sde".and i also have advance license and i also have permission to write because i have some other script to write directly inside feature and it is working even create a new featureClass.

0 Kudos
by Anonymous User
Not applicable

Hi,

For output please select local output FGDB data store or services side scratch workspace is used.

Vehicle routing problem analysis—Help | ArcGIS for Desktop 

Solving a vehicle routing problem in ArcMap—Help | ArcGIS for Desktop 

Haider_AliFaheem
New Contributor II

Thanks for your reply but i am not using it in desktop i want to use the solve vehicle routing problem in python .To test it i also tried in model builder but i have a same issue that i could not use enterprise geodatabase .

Solve vehicle routing problem it mention as following.

0 Kudos