Select to view content in your preferred language

Clobber Error when cloning ArcPy Environment

372
2
Jump to solution
06-03-2024 01:01 PM
MichaelPorter
New Contributor II

CondaVerificationError: The package for python located at C:\Users\xyz\AppData\Local\ESRI\conda\pkgs\python-3.7.11-1
appears to be corrupted. The path 'Lib/idlelib/__pycache__/zoomheight.cpython-37.pyc'
specified in the package manifest cannot be found.

CondaVerificationError: The package for python located at C:\Users\xyzx\AppData\Local\ESRI\conda\pkgs\python-3.7.11-1
appears to be corrupted. The path 'Lib/idlelib/idle_test/__pycache__/test_zoomheight.cpython-37.pyc'
specified in the package manifest cannot be found.

CondaVerificationError: The package for python located at C:\Users\xyzx\AppData\Local\ESRI\conda\pkgs\python-3.7.11-1
appears to be corrupted. The path 'Lib/idlelib/idle_test/test_zoomheight.py'
specified in the package manifest cannot be found.

CondaVerificationError: The package for python located at C:\Users\xyzx\AppData\Local\ESRI\conda\pkgs\python-3.7.11-1
appears to be corrupted. The path 'Lib/idlelib/zoomheight.py'
specified in the package manifest cannot be found.

ClobberError: The package 'esri/win-64::arcpy-2.9-py37_arcgispro_32704' cannot be installed due to a
path collision for 'lib/site-packages/arcpy_wmx/__pycache__/__init__.cpython-37.pyc'.
This path already exists in the target prefix, and it won't be removed
by an uninstall action in this transaction. The path is one that conda
doesn't recognize. It may have been created by another package manager.


ClobberError: The package 'esri/win-64::arcpy-2.9-py37_arcgispro_32704' cannot be installed due to a
path collision for 'lib/site-packages/gapy/__pycache__/__init__.cpython-37.pyc'.
This path already exists in the target prefix, and it won't be removed
by an uninstall action in this transaction. The path is one that conda
doesn't recognize. It may have been created by another package manager.


ClobberError: This transaction has incompatible packages due to a shared path.
packages: defaults/win-64::notebook-5.7.10-py37_0, defaults/win-64::notebook-5.7.10-py37_0
path: 'menu/notebook.json'

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
MichaelPorter
New Contributor II

Figured this one out.

Using the conda install that comes with arcpro at C:\Program Files\ArcGIS\Pro\bin\Python\scripts

Issue is that it's my work computer and I don't have write privileges to program files. Installed miniconda under c:\users\[username]\local and then did the cloning from there. Worked like a charm. 

Thanks for your help

View solution in original post

0 Kudos
2 Replies
DanPatterson
MVP Esteemed Contributor

did you use pip previously to install packages?  (conda won't touch them)

If you have old environments around, I would get rid of those first using conda and pip if appropriate, before you start cloning again


... sort of retired...
0 Kudos
MichaelPorter
New Contributor II

Figured this one out.

Using the conda install that comes with arcpro at C:\Program Files\ArcGIS\Pro\bin\Python\scripts

Issue is that it's my work computer and I don't have write privileges to program files. Installed miniconda under c:\users\[username]\local and then did the cloning from there. Worked like a charm. 

Thanks for your help

0 Kudos