arcpy.ExportTileCache_management() storage format not working

06-11-2020 10:13 AM
New Contributor III

In the course of automating my processes, I noticed that the storage format "EXPLODED" parameter is not being honored in a stand alone python script.  Every time I run the tool, it always outputs ".bundle" files.  It is supposed to output a folder structure with many ".png" image files.

import arcpy

    "EXPLODED", <----------DOES NOT WORK, seems to only use "COMPACT"/"COMPATV_V2"
    (288895.277144, 144447.638572, 72223.819286, 36111.909643, 18055.954822, 9027.977411),

This tool seems to work fine using the GUI in ArcGIS Pro.  This is ok, I guess, but my workflow involves many other steps, which are all automated in Python.

Using the exact same parameters and inputs, I have two different results:

Running the tool using the GUI in ArcGIS Pro, the output is correct:

However, using a stand alone python script, the tiles are not exploded.  Instead, they are still packed in a ".bundle" file.

Note: I've tried this with the input tile cached created with both the ArcGIS Pro GUI "Managed Tile Cache" tool and the stand alone "arcpy.ManageTileCache_management()" tool, which works as it's supposed to in both cases.

0 Kudos
0 Replies