ArcGIS Pro IDE not able to import arcpy

249
0
09-10-2020 01:22 PM
AhmadSALEH1
Occasional Contributor III

I upgraded Pro from 2.5 to Pro 2.6 , I have some *.py files that I want to edit / run. right now I am not planning to install any IDE so I am trying to use ArcGIS Pro IDE do the job. 

now when I try to import arcpy in my script I get the following error:

import arcpy

print ("Worked")

Traceback (most recent call last):
File "C:\Users\Ahmad\Desktop\d\test.py", line 2, in <module>
import arcpy
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\__init__.py", line 79, in <module>
from arcpy.toolbox import *
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\toolbox.py", line 403, in <module>
from .ga import SearchNeighborhoodStandard, SearchNeighborhoodSmooth, SearchNeighborhoodStandardCircular, SearchNeighborhoodSmoothCircular, SearchNeighborhoodStandard3D, CrossValidationResult, GeostatisticalDatasets
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\ga.py", line 33, in <module>
from arcpy import _ga
File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\_ga.py", line 30, in <module>
import gapy
File "C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\lib\site-packages\gapy\__init__.py", line 1, in <module>
from ._gapy import *
ImportError: DLL load failed: The specified procedure could not be found.

it looks like its arcpy specific  error, because when I try the following it works!

import sys
print (sys.version)

I get the following output:

3.6.10 |Anaconda, Inc.| (default, May 20 2020, 01:49:13) [MSC v.1916 64 bit (AMD64)]

 Thank you

Tags (2)
0 Replies