Maplex Forces Overrun - Labels Placed Where no Polygon Exists.

1429
2
07-29-2013 08:27 AM
ZdenkaHofman
New Contributor
I'm currently experiencing a handful of problems with the new maplex engine (10.1). The biggest issue is that the labeling engine for whatever reason forces my labels to overrun no matter what check boxes I have turned on or off.
It seems that the only solution at the moment is use an older version of Arcgis. Constantly saving down to older versions and switching systems just to use an older version for labeling... is frustrating...

I'm using land parcel placement and the only fitting strategy/density that I would like to use is reduce text size and minimum feature size for labeling. A lot of the time the maplex will force the label to be centered in the polygon, even though the polygon doesn't really exist at that spot. For example, if I have to two square polygons kitty corner from each other maplex will attempt to position the label in the center of the two. Here is an example of the problem. The number 10 is assigned to the green features. Not only is having the ten sitting on two different features horrifying aesthetically it also confuses the reader as to what that label is assigned to (the yellow, or the green?) [ATTACH=CONFIG]25744[/ATTACH]


Here is a couple more example highlighting problem areas. The image on the left has red circles highlighting problem labels.  The image on the right shows text in red how it should be.  This is just a small area of my map, there are hundreds of these problems throughout the whole extent of my map.  I'm not even mentioning the labels that are completely off centered (these can be seen in the example)
[ATTACH=CONFIG]26286[/ATTACH]

[ATTACH=CONFIG]26287[/ATTACH]


Does anybody know if any of these issues have been addressed with Maplex in 10.2? I'm always nervous about upgrading any of my software before the first Service Pack, but this is a huge problem for me and I need it fixed.

Thanks for the help!
Tags (2)
0 Kudos
2 Replies
by Anonymous User
Not applicable
Original User: Zdenkah

Anybody know if Maplex was touched in 10.2? Nothing in the What's New document but maybe some minor changes that didn't make it in the log. 
Some input would be great. I'm getting pretty desperate :(
0 Kudos
JonMorris
Occasional Contributor II
Hi Zdenkah,

There was no major new functionality added to Maplex at 10.2, only targeted bug fixes. That said, your labels should not have changed significantly with recent releases.

Can you check the following settings and see if the problem is still there?
Label Position tab > Options > Avoid holes = checked
Label Position tab > May place label outside polygon boundary = unchecked
Label Position tab > Place label at fixed position in polygon = unchecked
Conflict Resolution tab > Never remove = unchecked

In particular, the Never remove option should always be turned off, unless you are happy for either your labels to overlap, or some (or all) of your label properties to be ignored.

If you have the settings as above, and you are still having problems, there is probably a bug in the software. If you submit a support request to your local distributor or to ESRI Support Services an analyst such as myself will be happy to investigate the issue with you.
http://support.esri.com/en/

Thanks,
0 Kudos