Bitmap picture marker symbol do not export to pdf

6378
11
Jump to solution
03-28-2016 11:28 AM
AntoineCantin
New Contributor III

Hi,

When exporting my map to pdf, some of my picture marker symbols (little bitmap icons) do not export. Sometimes they appear in the legend, but sometimes not. Export options are as shown in the pictures. I tried to check the Convert Marker symbols to polygons without any luck. It's pretty weird and I can't figure out why. How can I solve this problem?

Thanks,

1.JPG2.JPG

0 Kudos
1 Solution

Accepted Solutions
AntoineCantin
New Contributor III

Only workaround I found: using .png files... Not great, because you can't change the color of the marker in ArcGIS, you have to use another software. This problem is pretty anoying, someone at ESRI should look at this bitmap / pdf export issue.

View solution in original post

0 Kudos
11 Replies
ChrisDonohue__GISP
MVP Frequent Contributor

One thing to try is to use the setting "Convert Marker Symbols to Polygons" (the one just above "Embed All Document Fonts") in conjunction with the ones you have already set.  Sometimes that will resolve the issue.

Chris Donohue, GISP

AntoineCantin
New Contributor III

I tried, but it's not working...

0 Kudos
ChrisDonohue__GISP
MVP Frequent Contributor

I found this in an older Help section (ArcGIS 10.0), but may still apply in modern versions.  Note - I added the underline:

Missing symbols in PDF, EPS, or SVG output

Map features symbolized with character marker symbols, such as point features, use fonts to graphically represent the feature. If you notice that certain features in the exported file render with text characters instead of graphic symbols, the ESRI fonts may be missing from that machine. Verify that the Embed All Document Fonts option is checked in the Format tab of the Export Map dialog box. Font embedding is supported for PDF, EPS, and SVG export, and allows the symbol to look the same even if the platform does not have the document's fonts installed. Note that some fonts do not support embedding and will not embed even when this option is checked.

Source:  ArcGIS Desktop

Chris Donohue, GISP

AntoineCantin
New Contributor III

Thanks again, but the bitmap markers in question do not contain any character/font symbols... Most of the time, they appear in the legend but not in the map itself.

0 Kudos
Salmon_ArmBC
New Contributor III

Are the bitmap markers symbolizing a point feature class/shapefile or are they part of an annotation group in the map?

0 Kudos
AntoineCantin
New Contributor III

They are symbplizing shapefile points.

0 Kudos
Salmon_ArmBC
New Contributor III

OK. In that case, I don't know what to tell you!

0 Kudos
AntoineCantin
New Contributor III

Only workaround I found: using .png files... Not great, because you can't change the color of the marker in ArcGIS, you have to use another software. This problem is pretty anoying, someone at ESRI should look at this bitmap / pdf export issue.

0 Kudos
PamelaLocke1
Occasional Contributor

Did you ever find a solution?  I have .png files as picture symbols for a point feature class, and when i try to export it to a pdf, some of them show up and some don't.....I have no idea why, but I really need this to work!  

0 Kudos