Citizen Problem Reporter - Send Emails Error

04-29-2019 10:53 AM
New Contributor III

I am trying to configure email notifications for the Citizen Problem Reporter (local government ArcGIS Solution) per these instructions. I configured the Send Emails tool and tried running but get the following error from the log:

ERROR: Failed to process service
(504, b'5.7.4 Unrecognized authentication type []')

I am not sure what is going on. I see this error pops up in other softwares when setting up SMTP. Some of the advice I've seen is to specify a port number, but I don't see where I can specify a port number. Does this have anything to do with the new TLS change? Let me know if further clarification is needed.

0 Kudos
2 Replies
New Contributor III

I have a similar problem.  The app cannot connect to the SMTP server. 

I have the email information like this in json configuration file:

       "email settings": {
           "smtp username": "",
           "smtp server": "",
           "smtp password": "password",
           "reply to": "",
            "from address": "",
             "use tls": true,
             "substitutions": null

The Python gives a few trials and return a exception with this error message:

   (421, b'Cannot connect to SMTP server (, connect error 10060')2019-07-02 11:07:59.829823

I also tried using hotmail (, as well tried using the SMTP server name found on my PC ( It returns the same error message.

Any suggestions?



0 Kudos
New Contributor III

I ended up checking the TLS checkbox and it worked.

0 Kudos