Strange behaviour in mosaic dataset… why?

410
5
07-12-2019 09:16 AM
Labels (2)
The_WeatherPartner1
New Contributor II

Normal sequence of rasters in a mosaic dataset: 

  • Each raster is a vector field with two components (bands): (u_10m_tr, v_10m_tr). The mosaic has been automatically populated with rasters from a single netCDF file.

Strange anomaly.

  • Look at #11 and #12: they are splitted, instead of being considered a single raster.

Why?

How can this be prevented?

Many thanks.

Jorge L. Navarro

0 Kudos
5 Replies
HongXu
by Esri Contributor
Esri Contributor

Jorge,

I cannot reproduce it. Could you try this: set  the parallel processing factor (in GP tool environment setting) as 1 and see if it is caused by running multiple processes. it could also be data specific issue. If you can reproduce the issue consistently, it would be good to contact technical support with data to reproduce the issue.

Thanks,

Hong, team raster

0 Kudos
The_WeatherPartner1
New Contributor II

Hong:

Many thanks for your response. Unfortunately setting parallel processing factor to 1 doesn't work. Yes, I can reproduce the issue consistently. I'll try with several dataset instances and have a in-depth look to see if it is a data specific issue (but with no much hope because the source netcdf is generated by an automatic process).

Last try, if it helps, here are two pop-ups: one for the well-behaved, and the other for the bad.

 

Hong, where can I find an authoritative and comprehensive tutorial explaining mosaic datasets in-depth?

Many thanks.

Jorge L. Navarro

0 Kudos
The_WeatherPartner1
New Contributor II

Hong:

I think this is NOT a data issue. Just tried with several cropped files (temporal, extent) of the original netcdf and the issue only appears with the original netcdf. Anything more to try? Open a technical support case?

Many thanks

Jorge L. Navarro

0 Kudos
HongXu
by Esri Contributor
Esri Contributor

Jorge,

It is strange that it works with other slices, not slice of 33, I thought something special with the data. yes, please work with technical support and log a case.

By the way which version of the software you are using? Pro 2.4 is released, maybe give it a try if you haven't. also in Pro 2.4,  if you only want to add a layer in map with vector symbol, you can use vector field raster function, this is supported in 2.4 only. 

Hong

0 Kudos
The_WeatherPartner1
New Contributor II

Pro 2.4. I will open a tech support case.

Where can I find an authoritative and comprehensive tutorial explaining mosaic datasets in-depth?

Jorge

0 Kudos