Very slow Geoprocessing

3083
3
01-09-2012 11:44 PM
TomGeo
by
Occasional Contributor III
Dear all,

I do have a serious problem here. Until recently everything was fine except from the usual things that bother everyone... Since yesterday my geoprocessing is terrible slow. It already starts when filling in the paths in the batch form of my model. A very simple thing, a selection by attributes. I need the input file, an SQL query and the output file. To fill in the path tho the input file and type the SQL statement, all no problem. However, when I go through the lines to fill in the path of the output file the form doesn't react in the first place, then it tells me that it is not responding and then it isn't able to refresh the canvas of the table in the batch form. Hence, I have to move the window out of the visible area of my screen, pull it back and the content is visible again. This is ridiculous!

After all that I start the geoprocessing and it is also terrible slow!

I checked the workspaces if there is any scrap left... nothing. The default database is empty the workspace folder is empty... I went through the install routine to repair ArcGIS - nothing changed! Server restarted - nothing changed!

My setup:

Windows Server 2008 R2 Enterprise (64-bit)
Service Pack 1
AMD Opteron Processor 6136 2.40 GHz
RAM: 32 GB

ArcGIS 10 (ArcInfo license)
Service Pack 3

Any other suggestions than changing the GIsystem?

Thomas
-------------------------
“GIS is a form of digital mapping technology. Kind of like Google Earth, but better.” ~ Arnold Schwarzenegger
0 Kudos
3 Replies
ChrisSnyder
Regular Contributor III
Some other things to try:

1. Compact the Default.gdb
2. Delete the geoprocessing history (in Windows 7 the history .xml files are in C:\Users\csny490\AppData\Roaming\ESRI\Desktop10.0\ArcToolbox\History)
3. Turn off/suspend/alter your virus scan software.
4. Delete your normal.mxt template file (make a backup first!!!). This file will autocreate anew when you fire up ArcMap again, but all your settings (toolbars, customizations, etc.) will be removed. In windows 7, C:\Users\csny490\AppData\Roaming\ESRI\Desktop10.0\ArcMap\Templates\Normal.mxt
0 Kudos
TomGeo
by
Occasional Contributor III
Hi,

thanks for the suggestions! I followed all your recommendations but nothing helped. It's same the same behaviour as before.

Thomas
-------------------------
“GIS is a form of digital mapping technology. Kind of like Google Earth, but better.” ~ Arnold Schwarzenegger
0 Kudos
curtvprice
MVP Esteemed Contributor
I'd do something a little more dramatic - reset all ArcGIS settings, not just the Normal.mxt.

1) close ArcGIS
2) Windows-Run...
3) enter "%APPDATA%" in the input box, this opens windows explorer in your %APPDATA% folder (XP or W7)
4) rename "ESRI" folder to "ESRIold"
5) Start ArcGIS again and see if anything is better. Note almost all your settings will be reset so you will have to re-create them.

Another thing to try is to make sure your ArcGIS search options are set to only run every 9999 days, ie only when you tell it to work. The search functionality can really slow things down.

If you are working over the network (remote file system) and the network has any latency, validation can slow to a crawl.
0 Kudos