Transformations are missing from vector and raster project tools

727
7
11-11-2016 10:48 AM
Oliver_Burdekin
Occasional Contributor II

When using the project raster or project vector tools there are no suggestions for datum transformations. Digging further I checked an existing map and tried to add a transformation to the data frame. The screenshot shows that no transformations are available.

It would appear that they have been deleted. Is there a way to reinstall them without having to reinstall Arc completely?

0 Kudos
7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Lets start with...were they ever there? have you tried one that isn't for global data like nad83 utm to nad27 utm?

0 Kudos
Oliver_Burdekin
Occasional Contributor II

Hi Dan,

Yes they were there. I have hundreds of .mxds and often need to apply transformations. Recently between WGS84 and Arc1950. Looking back over the last week's work I realised that in cleaning up my machine I had uninstalled ArcEarth and Arc App Studio. Presumably the uninstall from one (or both) of those two was a little overzealous and took all the transformations with them.

In order to fix it it was as simple as Control Panel > Programs and Features > ArcGIS 10.4 > remove / change > repair

Now they're all back.

Success.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Good... sometimes housecleaning can have side consequences.... this shouldn't happen though, particularly if more than one piece of software requires a shared object.

0 Kudos
Oliver_Burdekin
Occasional Contributor II

So I would've thought. The coincidence is striking though.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Oliver... It would be nice if you could report this so esri staff can test... anyone can file an incident report under support... it would just help someone else should they do the same

0 Kudos
Oliver_Burdekin
Occasional Contributor II

I'd be glad to Dan. Still testing at the moment. Checking Arc today the problem has persisted. I repaired the install again and everything is working okay. I'd like to try and find out what the cause is before reporting.

In addition, how do I go about reporting it to ESRI?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Oliver... through the support page... this is for the U.S Esri Support Contact Tech Support 

But countries normally have the last bits denoting regional support links (mine is Canada).  So you just sign into your account, then there is a web form at the bottom of the page on the left.  You don't need to be the administrator of the accounts (for multiparty organizations)

0 Kudos