Reverse geocoding address locator besides MGRS

2494
4
Jump to solution
01-26-2016 09:21 AM
johnpolo
New Contributor III

I am using geocoding for first time. Actually, reverse geocoding. I have roughly 4,000 points that I want to find addresses for. I used the Reverse Geocoding tool (Geocoding Tools) and it worked. The thing is, I only have a MGRS option for Input Address Locator, which gives me "military coordinates". I would like regular U.S. address, like '123 Pine St, Pine, CA'. How do I get the Reverse Geocoding tool to give me addresses in that format. Or is there another tool that will convert the military coordinates to the format I want?

0 Kudos
1 Solution

Accepted Solutions
BruceHarold
Esri Regular Contributor

Hi

You should add the World Service from geocode.arcgis.com, not tasks, then you will have this GIS Server:

GIS Servers\arcgis on geocode.arcgis.com (user)\World.GeocodeServer

It works with the Reverse Geocode tool, but be aware it will consume credits.

Regards

View solution in original post

0 Kudos
4 Replies
BruceHarold
Esri Regular Contributor

Hi

You should connect to ArcGIS Online in your session and use the World Service. you will get street addresses.

Regards

johnpolo
New Contributor III

Bruce, thank you for the answer. I had the Geocoding toolbar open and it prompted me to log in. I was prompted, so I am connected to ArcGIS Online. From there, I have access to the World Geocode Service through the Geocoding toolbar, but I need the Reverse Geocoding tool. I found this related thread and one of the respondents said:

"

Choose the Use GIS Services option and then for the Server URL on the next page, enter:

http://tasks.arcgisonline.com/arcgis/services

"

I followed the directions in that thread and I thought I was connected to the server, but I get the following error message:

"ERROR 000732

Input Address Locator: Dataset

tasks.arcgisonline.com\Locators\TA_Streets_US.GeocodeServer does not exist or is not supported

"

It seems like it's a live server when I navigate to it through the folders, so I don't know what is causing this error. Is the server changed?

0 Kudos
BruceHarold
Esri Regular Contributor

Hi

You should add the World Service from geocode.arcgis.com, not tasks, then you will have this GIS Server:

GIS Servers\arcgis on geocode.arcgis.com (user)\World.GeocodeServer

It works with the Reverse Geocode tool, but be aware it will consume credits.

Regards

0 Kudos
johnpolo
New Contributor III

Bruce, got it now. Thanks!

0 Kudos